Repair.IT – Eagnas Plus 8000 Electronic Tension Head

A follow-up to my recent “Review.IT” article is in order. This is the one where the load-cell had a wire pulled off of it. After some inspection of the load cell – that is, after removing the silicone compound that covers much of the strain gauges, I could see that everything else was intact. If I wanted to do the repair, all I had to do is to connect the yellow wire and then put a blob of silicone sealant on it.

Sounds easy, doesn’t it – except that the pads are very small and the wire is very thin. I put it onto a holder that allows the load cell to be held by clips, then positioned a magnifying glass over the load cell. In this way, I could clearly see the pad that I was soldering to, and of course the yellow wire. This was done in due course – then the other three load-cell wires were connected. All joins were then covered in heat- shrink.

SONY DSC

Load cell connected finally!

The other tension head came in as expected – so using this one, I was able to determine the load-cell connections. On inspection, the white goes to green, black to red, yellow to yellow (which was still connected) and red to black. The photo above shows the heat-shrink in place, but not yet shrunk.

SONY DSC

New Eagnas Plus 8000 internals

Here is the load cell and connector mounted back into the tension head with the chain re-attached.

SONY DSC

load cell attached with chain

Here is a close-up of the mounted load cell – I had to replace both of the screws that hold it to the chain and the carriage because the old ones had been stripped – I think because the original screws were not strong enough – hopefully, these ones will last longer.

SONY DSC

The New Eagnas Plus 8000

Now a final photo of the completed unit attached to my test bench ready to have its calibration checked and adjusted if needed.

By the way, notice how the blue gripper assembly doesn’t yet have the gripper installed? The reason for this is that I had to modify the assembly because the fastening screws were bent, by going through a 6.4 degree bend – that is the slope of the assembly relative to the horizontal. The holes drilled and counterbored in the assembly were perpendicular to the assembly, but were not lined up with the vertical holes in the mounting.

I put the gripper assembly into my mill and adjusted it to have a 6.5 degree slope, then used a 10mm end-mill to do the counterbore. This was followed by a 6.5mm drill to ensure that there was a vertical hole going through the assembly at the right angle. After doing this, the mounting screws can now be tightened up properly without having to bend in the middle.

The next tension head to look at is the one that came in, apparently had been smoking – and the transformer looks like it has been cooked, with the varnish having boiled out of it.

Review.IT – Eagnas Plus 8000 Electronic Tension Head

Just a couple of weeks ago, after the repaired Eagnas Plus 8000 Electronic Tension Head had gone back to the client, another came in – this time it had been opened, with case screws removed and no gripper head. I took the case off and found this.

SONY DSC

Broken load cell

Obviously, one of the problems of having an inline load cell – that is, a load cell that is connected in line with the pulling force, in this case the chain – requires that the fasteners that connect the load cell should not come apart. In the previous tension head, the bolt that connected the chain to the load cell had come off – however, in this case, the bolt that connected the load cell to the carriage failed, which meant that the wires to the load cell, the yellow one – had been pulled off.

Usually, this means getting a new load cell as it might be difficult or near impossible to repair. Another thing is that getting an equivalent load cell could be difficult if the manufacturer is unwilling to provide spare parts – which is the case in this situation.

On the bright side, I realized that one of my digital luggage scales that I use to check the tension heads might use a similar load cell – and it seems to be the case.

SONY DSC

Digital luggage scale – cover removed

I opened my luggage scale and sure enough, the load cell is the same size – but is it similar enough? The wiring color is different, green, white, red & black instead of yellow, white, red & black. The notation on the circuit board indicates that green is +excitation, and black is -excitation, hence white is +signal, and finally red is -signal.

I found a site that showed some load cell wiring colors – Load Cell Wire Colors which shows that this is a common wiring arrangement, so that is good to confirm.

Now the broken load cell has yellow – probably instead of green. The load cell strain gauges are covered in a soft silicone sealant for protection, and I could scrape it off and have a look at the strain gauge and see if I could perhaps reconnect the yellow wire.

SONY DSC

Load cell

It looks like I can reconnect the yellow wire as it had broken off on the solder pad.  If I reconnect the yellow wire, I then need to work out where the other wires should go to – three wires to connect to three other wires – what could go wrong? Ok – the yellow wire is still connected to a yellow wire, so the other wires on the connector are red, black and green – so presumably, red to red, black to black and green to white would be an obvious first try.

Anyway, I don’t have to rush on this repair because the client came back to me saying that the other one I had repaired had started smoking and his customer no longer wants them both, so now I can wait until the other tension head comes back eventually and check the wiring colors. In the meantime, I might order a similar load cell from aliexpress.

[P.S. When the smoke leaves a machine, it generally stops working, until we can repair it to put the smoke back in.]

 

 

Reassemble.IT, Repair.IT – Eagnas Plus 8000 Electronic Tension Head

Last Saturday, I got a message that there was a Eagnas Plus 8000 Electronic Tension Head for me to look at. It was apparently new, but not working. I picked it up on Monday, after it had been returned by the customer.

This is a newer model of the Eagnas Plus 8000 that I had worked on previously – a white case instead of the older grey case. This one had been sold to a customer who said it wasn’t working, so the supplier sent a spare circuit board to the customer. Due to some problem with the assembly, it came back to the supplier – which is where I got involved.

The gripper assembly had been removed already – when I examined it, I noted that the microswitch wasn’t clicking when the white plastic actuating lever was pressed. I knew from previous experience that this would cause an error in the self test procedure that would stop the tension head from working.

I proceeded to remove the case and found that the internal circuit board had been removed from its supports, and cables had been removed from the board. Also I found that the drive chain for the carriage was disconnected. This tension head differs from the older one by using a different load cell, a much smaller one, which is connected in line with the drive chain. The older model used a much larger load cell (and probably more sensitive) which was indirectly coupled to the carriage.

Anyway, I had to reassemble everything before I could test it and work out what problem it had other than the suspect microswitch. This reassembly took some time, to remount the circuit board, and while attaching the cables, I found a couple of the contacts on one cable were a little loose – which was causing heating at the contact point. I removed the contacts and adjusted them so that there was better contact between the pins.

Next was to reconnect the chain. The bolt that had been used was a M4 bolt which was bent, and the end was stripped – looks like the nut had pulled loose. If that was the case, perhaps it had not been tightened properly in the factory. I replaced the bolt with a M4 bolt from my nuts and bolts collection, cut to the appropriate length and tightened up. The chain was then reattached which took some effort because it has a spring inside the joiner, but eventually it was done.

I then examined the microswitch which is mounted at an angle so that the plastic lever pushes the switch lever down, however – the switch lever was not bent to the correct angle, so when assembled, the switch was always activated. I bent the lever to an angle such that when assembled, the switch was not pressed. Then pushing down on the white plastic lever, I now heard the familiar click of a working microswitch.

SONY DSC

Switch assembly

Here you can see the white plastic lever – and next to it, the silver microswitch lever. Pressing the white lever pushes down on the silver lever.

I then connected the switch cable and plugged in the power cable, and was glad to see that the self test shows three ticks.

SONY DSC

Eagnas display panel

From experience, if the switch was pressed or not connected at power on, there will be a cross next to 3. Load-cell cable instead of a tick – which can be a red herring, since you need to know that the load-cell cable doesn’t just connect to the load cell, but also to the gripper microswitch. Most people don’t know this, and hence suspect that the circuit board might be the problem.

Once everything was back together, I set the tension to about 20 lbs, then put some string into the gripper with a digital luggage scale to pull and see if it stops pulling, which it did, but it wasn’t at 20 lbs, more like 14 lbs – which is probably ok. Why is this? Because the tension head is usually calibrated at the factory to suit tennis tensions at 50 or 55 lbs. If this tension head is going to used for badminton, then we would adjust the calibration to be more accurate at around 25 lbs. If the user has a digital luggage scale, they can also test it at various settings and end up with a calibration chart which shows what setting gives a particular tension.

SONY DSC

Eagnas Plus 8000 Electronic Tension Head

Here is a final photo of the assembled tension head before I put it back into its box – looks quite nice, doesn’t it.

[Note] Other work done on this was to fix up the slide covers, that had been wrinkled a bit and to realign the slide cover guides to be parallel to the carriage movement. Not doing this causes the slide covers to jam.

Retell.IT – 2013 – Repair of Eagnas Plus 8000 electronic tension heads for stringing machines, a lot of them

Recently the topic of Eagnas tension heads have come up, so I went back into my log books to look at a suitable article to write. So, here goes.

Back in June 2013, I was contacted to see if I was interested in repairing some Eagnas Plus 8000 electronic tension heads. I said that I was interested, and in the following days, collected four of these to look at. These tension heads are used for racquet stringing machines and are not cheap. Very little information was forthcoming about the condition of these tension heads other than that they were not working properly or something like that and they need to be checked and/or repaired.

Tension Head 1 would turn on but wouldn’t move – the gripper head was jammed.

Tension Head 2 had crumpled slide covers. This tension head would turn on, but as the gripper head moves,
it would jam on the slide covers, hence these covers are broken and crumpled.

Tension Head 3 would turn on, but soon afterwards would start beeping.

Tension Head 4 would turn on, but didn’t seem to be able to move the carriage. Pressing the nylon switch
lever to indicate the start of a string pull did not move the carriage.

Ok, so quite a few different problems. I started looking at the ones that would turn on.

To open these tension heads, I had to do the following – with Tension Head 3 to start with.

Unscrew the switch cover on the side of the string gripper. Knock out the gripper fastening pin allowing the gripper to be removed. The gripper housing and diablo is held by two machine bolts – remove them. There is a switch cable plug and socket arrangement, disconnect it by removing the glue surrounding it and then separating the connectors. Remove four bolts that fasten the head cover. Lift the cover on the left, then push the cover to the right to clear the power switch, then lift it up and tilt it towards the back. For better access, disconnect the display board ribbon cable. Now, we can also remove the slide covers, and then we can work on the tension head reasonably easily.

SONY DSC

This particular Eagnas tension head uses a geared motor with sprockets to turn a chain that moves a carriage on a slide, to which is attached, a gripper and a load cell. The gripper is mounted on top of a plate that is attached to the carriage about a third of the way down, and the other end will press onto the load cell. The load cell, being fastened to the carriage, is used to measure how much force is acting on it by this plate when the string is being pulled, indirectly by the chain. This seems to be a reasonable way of working and should be quite accurate and repeatable.

SONY DSC

Here is another photo of the mechanism. The load cell is the aluminium block on the left, you can see the chain, with lots of grease on it. There is also a fair bit of debris inside, metal shavings, drops of hot melt glue, etc – more on this later.

Continuing on, with opening the others …

Tension Head 1. Further investigation showed that the chain had come adrift, and wrapped itself around the motor sprockets. It seems that the chain’s master link had come off, and the master link’s side plate and locking plate were not to be found. I was able to connect the chain together temporarily and was able to confirm that the tension head appeared to be working, therefore I need to order a replacement master link to properly fix this tension head.

Tension Head 2. The slide covers were crumpled because they move in a slot that is not lined up with the carriage movement. Think of train tracks with the carriage in the middle – in this case the carriage was moving to one of the rails forcing the slide covers to crush. I was able to fix this by realigning the slide slots so that the carriage moved in the centre and parrallel to the slide. A bit of bending of the metal supports was what was needed.

Tension Head 3. This tension head had a noticeably loose load cell, but would beep again – so look at this later. Also it would not power up from time to time.

Head 4. Once I opened the tension head, I was able to find that a wire had come off from a switch. Resoldering this wire to the switch allowed this tension head to work again. I also found that the switch lever that is on the gripper was missing a spring. This lever is pressed in order to start the string tensioning. I was able to cut a similar spring to the appropriate size and fit it to complete the repair.

As the customer was in a bit of a hurry for a tension head to be ready, I took the slide
covers from Tension Head 3 and put them onto Tension Head 2. After that was done, it was reassembled and was tested to be working fine. Thus, I had two tension heads working and returned these two to him. He then gave me another tension head to look at that had been returned by a dealer.

Continuing on with these tension heads, I found that Tension Head 5 would turn on but didn’t seem to be able to move the carriage.

Quite a few different symptoms. Further work showed that several of the load cells were loose – not fastened firmly would mean inconsistent tension readings that would suddenly jump, not really a good thing. Another thing I found was that the carriage assemblies were sometimes very tight around the pivot bar due to the bearings being either too tight or too loose, and the side plates of the carriage not being parallel. This was when I found that many of the parts that hold the side plates of the carriage together are differing lengths, hence they used washers to adjust the width, and most of the time, ended up with screws that were too tight and others that were not holding.

I decided to rework these carriages by measuring the shortest support bar, and machining everything else to fit, so that without washers, the side plates would fit properly and the carriage was secure without excessive force on the screws. I also found some bearings had no grease, which explained why some were hard to turn. Regreased those bearings with lithium grease. The chains also had excessive grease on them which accumulated around the sprocket wheel – much of this excess grease was removed.

Load cells were adjusted and tightened – but not too tight, so as not to deform the load cell mountings. I also adjusted the contact point of the pivot plate where it presses onto the load cell – there should be a small gap, about 1mm or so when the system is idle without tension. Much of this work was spread out over several days as I did not always have time to work on these tension heads.

Tension head 5 – found that the motor connection was intermittent. On the other machines, the motor connector was glued together – this one did not have glue, but would work if I pushed the connector together and if I pulled it apart a little, it would stop working.

SONY DSC

That is the connector in the middle of the photo – I then tied the connector together and glued it so that it would not come apart easily. I also found a master link locking plate in the bottom of the tension head. When I connected the gripper switch, I found that the carriage would not move. One of the gripper switch cable connecting pins was slightly shorter and was not making contact. Just had to push the pin in further to make contact then glue it in place. Another tension head fixed.

Tension Head 3 – I found out that the beeping was caused by the knot tying switch on the control panel was nearly always pressed down. This was fixed by moving the control panel a little so there was no pressure on the switch. That fixed the beeping. Then during the testing, this tension head stopped working. After tracing the wiring, found that one of the wires going to the 240/110V voltage selector switch was loose – pushing it back in, allowed the machine to power up. Resoldered that wire and checked the others at the same time. Now this tension head was fixed.

I returned these two tension heads back to the customer, and he gave me two more to look at. That would be a total of seven machines in all.

Tension Head 6 would not turn on. The motor doesn’t make a little jump like some of the others, no display – nothing.

Tension Head 7 would not turn on. It was missing a 2A M205 fuse and fuse cover – that could explain it, but was it that simple?

I opened up Tension Head 6 and checked the voltage selection switch. Sure enough – one of the wires was adrift, it might be a common problem to look for in future. Resoldered this wire. Still no power – what is happening? I could see power going in then no power to the board. Eventually I found that some of the secondary windings had been cut due to the motor pressing onto the transformer – how is this possible?

SONY DSC

Ok, it was due to the way the motor is mounted and the lack of clearance to the transformer. We can see from the earlier photo with the motor connector, that the motor sits very close to the transformer – another thing that needs to be checked.

SONY DSC

Now after repairing these wires, I moved them below the top of the transformer before I remounted the motor assembly. After reassembly, the carriage would move when I press the switch, but it shows no tension reading – strange. I checked the load cell connections because the wiring looks different to the others. It looks like someone had played with it and reversed the red and black wires – I swapped it back around – still nothing. Anyway, it turned out after tracing through the circuit, that a transistor had failed – 2SC2236Y. I was able to get a equivalent NTE382 transistor to replace it. Still not working – ok, a long story short is what is needed – eventually I managed to determine that the ADC had failed. This was a Sony CXD1175 small outline ic that was no longer in production, but I was able to order a TLC5510AINS that was an equivalent.

SONY DSC

Sorry, the photo of the board showed the chip upside down – the one in the middle – that is why the board looks a bit strange. Anyway, removing this with the use of ChipQuik was relatively easy then soldering the TLC5510AINS using solder paste and a hot-air rework station was also uneventful. After a quick calibration adjustment, this machine was fixed.

Now back to Tension Head 1 – the 25H master links that I ordered came in eventually. The wrong links came in first, then they had to resend the right ones – it seems that both links had the same item code. Installing the master link allowed the machine to work, and after a quick check of calibration – this tension head was also ready to go, except that I had used its slide covers to replace those on Tension Head 3 that had been used on Tension Head 2. I bought some grey card stock and made new covers to fit this machine.

Tension Head 7 – the one that was missing a fuse and fuse cover, I replaced the fuse, but didn’t have a fuse cover. That was all that was needed to fix this machine – an easy one.

So, in summary, most of these machines had similar issues, problems with the carriage, load cell – wiring that was coming apart – they are generally manufacturing problems. Debris from manufacturing was also inside the tension heads – I vacuumed them out as much as I could before returning them to the customer. The missing chain link plates – could it be carelessness? If they had come apart, which is very unlikely, then I should have found the pieces inside, but then I found a locking plate in Tension Head 5, which wasn’t missing one.

Tension Head 6 was the one which required the most electronic repair, with the broken wires in the transformer from the motor pressing on it. I suspect that someone tried to fix it, by playing around with the load cell wiring – why on earth someone would do this – I don’t know, but that likely caused the transistor to fail, which then put more than 5V onto the ADC, something like 12V more likely – and that caused the ADC to fail. Did the ADC failure then cause the motor to continue pulling and cut the wires? There is a microswitch that should limit the carriage movement to prevent this happening – anyway, a combination of events came together that meant that this tension head was the hardest to repair.

In the repair business, we often get easy ones and sometimes hard ones. There is a 90/10 rule or is it the 80/20 rule?