Repair.IT – Asus Taichi 21 Notebook

This follows on from my data recovery of the D: drive of the Asus Taichi 21 notebook.  Actually, it wasn’t really so much data recovery as just copying files and folders from the SSD drive once I had it mounted, but this is about the repair of the notebook.  After I returned the notebook and the data, I was told that the owner would order a replacement motherboard and let me know when it came in so I could then fix the notebook.

In due course (a week and a half later), the motherboard arrived from the US and I got the notebook back. By the way, I didn’t mention about opening the case – there are 10 little Torx screws to be removed and then the two plastic feet near the hinges can be removed to uncover two more Phillips screws.  Then I disconnected and removed the battery, and then removed the heatsink/fan assembly.

dsc_0292

Once the heatsink came off, I could see that the cpu was covered with excessive amounts of thermal interface material – actually only the top of the cpu that contacts the heatsink needs the thermal interface material.  Then it was a matter of disconnecting and removing the wireless card, and the other connectors – then put in the replacement motherboard and reconnect everything.  For the heatsink, I used Arctic Silver thermal material to cover the top of the cpu as a thin film, then put the heatsink on top, jiggled it around a little, then screwed it on firmly.  The last thing was to install and connect the battery.

While powering on, I did notice that occasionally the screen would flicker but it stayed on most of the time, and when I closed the lid, the back screen came on as expected, so that was that – or was it?

The notebook went back to its owner the next day, and all was well – there was the occasion that the screen did not light up but after updating drivers, all appeared to be well.  At least until the owner tried to connect a couple of external monitors and somehow there was no display anymore.

I got the notebook back and I thought it would be strange if the motherboard was faulty again – but it is possible since they might only test it for a short time.  After some examination and reconnecting of the two screen cables, I found that one of the the connectors might have been a little dodgy, so I had to unplug it, then plug it in, unplug it and do this a few times – each time ensuring that it was lined up and would click back in securely.  This seemed to fix it and was able to get a working screen consistently and told the owner what I had done in case it happened again.

That was a couple of weeks ago and nothing has been heard of it since, which I guess is good news.

Advertisements

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s