Recover.IT – Netgear Stora MS2110 NAS

Just last week, I was given a Netgear Stora MS2110 NAS to look at. I was shown that when powered on, only the orange HDDLED2 would light up – a symptom of it not working. They wanted the photos that were stored on it, that I expect were from many years ago. I could hear the internal disk drive spinning up, which was a good sign.

The disk drive is a Seagate Barracuda LP of size 1TB. The front cover slides off the NAS and then the single disk drive can be ejected using a lever at the back. This NAS could handle two disks, but only one had ever been installed. The first thing that I usually do, is to connect it to my Linux test machine. However, in this case – my test machine would not boot. It had occasionally done this in the past, but usually has then worked after a couple of tries. I plugged in my diagnostic card – which goes into a PCI slot, then powered on to see what was going on.

SONY DSC

PC Diagnostic result

The diagnostic card shows that the motherboard has stopped when checking the memory – DIMM. Ok, so what is wrong with the memory – it was a pair of 2GB DDR2-800 memory sticks. I checked my stock, and I had a Kingston 4GB set of DDR2-800, so swapped them in.

Now, it boots – ok, to proceed with the data recovery. I opened a terminal session, then ran “dmesg | grep sd” to check which disk is the 1TB drive – it was sdb. Here is the result of “dmesg | grep sdb”

Screenshot - 080616 - 114907

From this output, I can see that there is a partition called sdb1 on this disk drive. Next is to see what kind of partition it is.

Screenshot - 080616 - 133159

It is a partition type “0xfd” – Linux RAID partition. I needed to run the fdisk with the sudo command as a normal user cannot access disk devices directly. Since this was a single disk RAID, it is safe to assume that if the partition can be accessed, that the data is most likely intact.

Generally, the Netgear Stora uses a xfs partition which is slightly different to other common linux file systems. Ubuntu which is running on my test machine can handle xfs partition types, so to do this – I need to mount it. Just a word of caution – you will note that I haven’t copied the disk as yet – the reason is that my network storage is a bit full and cannot handle an extra 1TB of disk image. Anyway, I am just going to mount the partition and check the contents – if it is small, I can copy everything from it quickly without having to image the disk.

Screenshot - 080616 - 133332

The first command is to create a mount point for the disk, that I have called /mnt/nasdisk. The next command mounts the /dev/sdb1 partition as a xfs file system type in read-only mode. Then a ls command to list the files and folders shows folders.

Screenshot - 080616 - 133432

I opened this mount point in the graphical File Manager and can see that I can access 0common and going in, I could see various folders and the like – so I quickly copied those out to my network drive. The other folders with the X have permissions which I cannot access, so I will need to be the root user to get to them. I also checked with the df command to see how much was used in all of the file systems – only 11GB or so on this disk.

To do this, you need to run the File Manager with root permissions – which requires the package gksu to be installed in Ubuntu. I did this, then ran the command “gksudo thunar” and then navigated to this mount point.

Screenshot - 080616 - 133620

Success, the other folders now were accessible. This time, the File Manager has this orange line that tells you to be extra careful – as it is easy to do things when using the root account that could destroy your computer. I then proceeded to copy any other folders that contained file. All in all, there was just over 10GB of data – I ignored anything that had to do with the Stora software – like web pages and the like.

The Netgear Stora hardware seems to have failed – it could occur for many reasons, and could possibly be repaired but as I was just asked to get the data, then Recover.IT is what I did.

[Note]  It seems that many people on the internet have had problems with the Netgear Stora – but it might be that if you look for anything at all, you might find that everything also has problems. I did see though, that a lot of people had problems accessing xfs partitions – but that may be due to the various linux flavours. FreeBSD for example had read-only support for xfs in 2005, then removed it from version 10 in 2013. Maybe that is why I stay with Ubuntu.

[Note 2] My original memory seems to have developed a problem. I cleaned the contacts on the DDR2 memory using alcohol wipes, as come contacts were dirty. Eventually after further testing, I could have one memory dimm installed and working but not both. The Kingston memory though would work with both dimm slots occupied.

Advertisements

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s